下面由Composer教程栏目给大家介绍解决git-bash下composer命令无法使用的问题,希望对需要的朋友有所帮助!

解决git-bash下composer命令无法使用的问题插图

git-bash下composer命令无法使用的问题

已经安装composer,写好composer.bat,并且设置好了path,在cmd下可以正常使用,但是在git-bash里面不行,其实真正的原因是,git-bash 不识别 composer.bat 文件,需要新建一个 composer 文件,输入如下内容:

#!/usr/bin/env sh
# php /path/to/composer.phar $*
php `dirname $0`/composer.phar $*

#!/usr/bin/env sh 有个这一行,git-bash 会自动识别为可执行文件,不需要也不能使用 chmod 命令修改权限。

以上就是解决git-bash下composer命令无法使用的问题的详细内容,更多请关注811轩轩资源网其它相关文章!

声明:本文转载于:cnblogs,如有侵犯,请联系admin@php.cn删除

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注